Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | See parent post | Go Back
View Post [edit]

Poster: Administrator, Curator, or Stafftracey pooh Date: Jan 25, 2012 10:57am
Forum: movies Subject: Re: new video/audio player 'opt in' is live!

Thanks again Tyler for another spin!

(1) yah, we identify the duration for each A/V file, for what gets used in the track listing and at the start of playback. but that is sometimes off by a bit. no real resolution there, but the player *should* correct it to the right time once it starts loading/playing.

(2) a brewster request -- for more "branding". and unfortunately, we can only easily insert 1 extra button into the "controlbar" area, reliably, so we went the the [|||] logo instead of [>] share

(3) kinda taking cues from brewster chat on that one, re; the text choice...

(4) yay!

(5) it's just that they don't quite "fit" for audio in flash mode. we could make the player wider to accomodate, but we might get some folks not liking more horizontal space to the player? maybe we can revisit this idea once the "old player" is gone (and the world is easier to change)?

(6) yay!

(7) that's a good idea, but would take some time to pull off as I had to render these pngs myself and then recompile the flash portion of the player to include the pngs...

(8) yah, that's an example of our "slimmer / unified" header and colors. it's slowing rolling out in a few pages (eg: http://www.archive.org/details/1Day http://www.archive.org/911 ) and hopefully one of these days it or something similar become more of the default for our pages.

(9) fixed, thx!

(10) yes, it's intentional because not all items will have 2+ A/V files in them and I wanted a "stable example" of an item for each of audio/video to show it in a sensible way. I but a big note for it now to explain there's a different ID 'in play' for that (and now only that) example embed.

(11) great idea -- dunno why it didn't occur to me to do that!! fixed, thx!

(12) yes, you are right about 64kbps -- they have this (not obvious) asterisk where it's noted at the top:
(*) Some derivatives only apply to certain collections.
As far as .m3u or .zip files -- those are 100% generated on-the-fly now, on demand -- so we don't mention them in the derivative table since we don't technically make them (and thus don't put them into the item directory)

(13) good call -- you have to hover for video, but not audio. I've updated each page respectively, thx!

(14) you continue to be one of our amazing assets here at the Archive! Happy NY!

-tracey


Reply to this post
Reply [edit]

Poster: Vlax Date: Apr 24, 2012 7:23am
Forum: movies Subject: Re: new video/audio player + "specific audio file"

I'm trying to use the feature to include a specific audio file; as the audio help page says:

[iframe src="http://archive.org/embed/jj2008-06-14.mk4/jj2008-06-14d2t04.flac" width="500" height="30" frameborder="0"]

using this (obviously with the correct < >) it shows correctly the player for a single file; but it's not working for my item (http://archive.org/details/WarscapeSonata), player it's not showing anything:

[iframe src="http://archive.org/embed/WarscapeSonata/WarScapeSonata_Detenido-en-posesion.mp3" width="500" height="30" frameborder="0"]

even if you try to use another file from the same example item (http://archive.org/details/jj2008-06-14.mk4/), player it's not showing anything:

[iframe src="http://archive.org/embed/jj2008-06-14.mk4/jj2008-06-14d2t01_vbr.mp3" width="500" height="30" frameborder="0"]


-------------

My browser test results:
Do we think: you have loaded jwplayer? ... yes

...jwplayer parsed properly? yes

...you have flash? false

...alternate hasFlash() check? no

This appears to be your agent string: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0 Iceweasel/11.0

extracted filename: /download/camels/camels.mp4

flashCanPlay() result: true

best we can tell, you see a [Play] style button above. If *NOT*, please contact info@archive.org with subject like "from forums: tell tracey cant see play style button in test"

Trying embed of: flash (only), default skin, mp4 only, minimal, autoplay: